Upcoming Events

No events to display

We are not planning any more in-person events until the COVID-19 situation has improved.

Scrollbars Missing? Update Windows to 20H2 (ex Lost My Levers!)

You are here: Home > Forum > General > General questions, comments, and issues > Loader V5 > Scrollbars Missing? Update Windows to 20H2 (ex Lost My Levers!)

Page 2 of 2

Lost My Levers! 19/04/2021 at 01:12 #138801
bill_gensheet
Avatar
745 posts
Tried Westbury, new run with no timetable.
Using several frames but spent most time on Warminster sidings (not MoD).

Works OK, but be careful if thinking things do not work as severa;l of these frames have inbuilt timers.



OS: Windows 10 Enterprise 64bit
Loader: SimSig Loader version 5.15; Sim: Simulation Westbury; data version 4.4
License: Tester mode
TT: None v0.0.0
TT filename:
TT merged: False
Sim upgrade: False
Loader upgrade: False
Save reloaded: False
NPERFECT active at start
NBEGINNER choice 1
NSTANDARD choice 2
NWESTAVOID choice 3
NSTORM choice 4

Log in to reply
Lost My Levers! 19/04/2021 at 01:55 #138802
GeoffM
Avatar
5613 posts
Online
While I can't recreate the display issue on this PC (first chance I've had to get 5 minutes in front of it), I acknowledge there are a couple of issues with frames. I'm going to work on it tomorrow. Apologies for the inconvenience.
SimSig Boss
Log in to reply
The following users said thank you: Meld, Peter Bennet
Lost My Levers! 19/04/2021 at 08:23 #138803
Dick
Avatar
329 posts
Fine here, with Windows update KB5001330 installed


OS: Windows 10 Enterprise 64bit
Loader: SimSig Loader version 5.15; Sim: Simulation York North and South; data version 1.11
License: Locked license in use
TT: None v0.0.0
TT filename:
TT merged: False
Sim upgrade: False
Loader upgrade: False
Save reloaded: False
NEASY active at start
NNORMAL choice 1
NSC2 choice 2
NP17 choice 3
NUDL choice 4
NARSX choice 1
NSTDARS active at start
NERA2004 active at start

Log in to reply
Lost My Levers! 19/04/2021 at 09:24 #138804
simple68
Avatar
20 posts
Working fine for me

OS: Windows 10 Enterprise 64bit
Loader: SimSig Loader version 5.15; Sim: Simulation York North and South; data version 1.11
License: Dynamic license in use
TT: None v0.0.0
TT filename:
TT merged: False
Sim upgrade: False
Loader upgrade: False
Save reloaded: False
NEASY active at start
NNORMAL choice 1
NSC2 choice 2
NP17 choice 3
NUDL choice 4
NARSX choice 1
NSTDARS active at start
NERA2004 active at start

Not sure if its relevant but I use Chrome as default browser

Si

Log in to reply
Lost My Levers! 19/04/2021 at 11:38 #138807
Peter Bennet
Avatar
5023 posts
Mine is:

OS: Windows 10 Home 64bit
Loader: SimSig Loader version 5.15; Sim: Simulation Westbury; data version 4.4
License: Locked license in use
TT: None v0.0.0
TT filename:
TT merged: False
Sim upgrade: False
Loader upgrade: False
Save reloaded: False
NPERFECT active at start
NBEGINNER choice 1
NSTANDARD choice 2
NWESTAVOID choice 3
NSTORM choice 4


Interestingly I tried launching on loader 5.8 which I still have and I get exactly the same problem. That suggests to me it's a problem linked to Window's, but I don't claim to be anything of an expert on computers.

Peter

I identify as half man half biscuit - crumbs!
Log in to reply
Lost My Levers! 19/04/2021 at 13:03 #138808
Diesel Rider
Avatar
53 posts
Launched Westbury yesterday as new layout in forums, Runs perfectly levers working fine all over and this after windows update, but the issue is 0x00 enters but not listed in f2 yet calls for permission to move even though route set for the shunt to up rec then rev to down yard. Phoned down yard and they gave permission for 7-12. 0x01 enters as normal down yard no problem same with any other train.
OS: Windows 10 Home 64bit
Loader: SimSig Loader version 5.15; Sim: Simulation Westbury; data version 4.4
License:
TT: DPE_New Westbury TT v0.0.0
TT filename: DPE_New Westbury TT.WTT
TT merged: False
Sim upgrade: False
Loader upgrade: False
Save reloaded: True
NPERFECT active at start
NBEGINNER choice 1
NSTANDARD choice 2
NWESTAVOID choice 3
NSTORM choice 4

Log in to reply
Lost My Levers! 19/04/2021 at 17:23 #138823
GeoffM
Avatar
5613 posts
Online
Peter Bennet in post 138807 said:
Interestingly I tried launching on loader 5.8 which I still have and I get exactly the same problem. That suggests to me it's a problem linked to Window's, but I don't claim to be anything of an expert on computers.
That and the original post was before V5.15 of the Loader, and a few months after the previous version with no intermediate reports leads me to agree.

The GF window has its controls dynamically added at runtime, as opposed to nearly every other window in the Loader. The only one I can think of that adds dynamically is the Start New Simulation -> Select Options tab but that does not have any sliders.

For those that are having display issues and have Three Bridges, does the Coulsdon North GF work okay? Bear in mind there is a 120s timeout after pressing the F before the release can be taken. There are no sliders on this GF. Also, just to be sure, are the F3 (Options) -> Failures sliders working?

SimSig Boss
Last edited: 19/04/2021 at 17:24 by GeoffM
Reason: None given

Log in to reply
Lost My Levers! 19/04/2021 at 17:39 #138824
andyallen4014
Avatar
179 posts
GeoffM in post 138823 said:
Peter Bennet in post 138807 said:
Interestingly I tried launching on loader 5.8 which I still have and I get exactly the same problem. That suggests to me it's a problem linked to Window's, but I don't claim to be anything of an expert on computers.
That and the original post was before V5.15 of the Loader, and a few months after the previous version with no intermediate reports leads me to agree.

The GF window has its controls dynamically added at runtime, as opposed to nearly every other window in the Loader. The only one I can think of that adds dynamically is the Start New Simulation -> Select Options tab but that does not have any sliders.

For those that are having display issues and have Three Bridges, does the Coulsdon North GF work okay? Bear in mind there is a 120s timeout after pressing the F before the release can be taken. There are no sliders on this GF. Also, just to be sure, are the F3 (Options) -> Failures sliders working?
Hi Geoff,

I have no failures sliders on Three Bridges.

However, the Couldson GF works as it should.

Andy

Post has attachments. Log in to view them.
Last edited: 19/04/2021 at 18:07 by andyallen4014
Reason: Added info on Couldson GF

Log in to reply
Lost My Levers! 19/04/2021 at 17:47 #138825
andyallen4014
Avatar
179 posts
One for John - here is the York save.

I have a snapshot, but not until 22.00 which was after the point the GF was required, we had restarted the session at 21.30 sim.

Post has attachments. Log in to view them.
Last edited: 19/04/2021 at 18:13 by andyallen4014
Reason: None given

Log in to reply
The following user said thank you: Meld
Lost My Levers! 19/04/2021 at 18:18 #138826
GeoffM
Avatar
5613 posts
Online
andyallen4014 in post 138824 said:
GeoffM in post 138823 said:
Peter Bennet in post 138807 said:
Interestingly I tried launching on loader 5.8 which I still have and I get exactly the same problem. That suggests to me it's a problem linked to Window's, but I don't claim to be anything of an expert on computers.
That and the original post was before V5.15 of the Loader, and a few months after the previous version with no intermediate reports leads me to agree.

The GF window has its controls dynamically added at runtime, as opposed to nearly every other window in the Loader. The only one I can think of that adds dynamically is the Start New Simulation -> Select Options tab but that does not have any sliders.

For those that are having display issues and have Three Bridges, does the Coulsdon North GF work okay? Bear in mind there is a 120s timeout after pressing the F before the release can be taken. There are no sliders on this GF. Also, just to be sure, are the F3 (Options) -> Failures sliders working?
Hi Geoff,

I have no failures sliders on Three Bridges.

However, the Couldson GF works as it should.

Andy
Thanks.

Although I could not reproduce it on my desktop, I *can* reproduce it on my laptop. And yes, I just noticed the Failures tab is borked as well.

SimSig Boss
Log in to reply
Lost My Levers! 19/04/2021 at 18:35 #138827
Peter Bennet
Avatar
5023 posts
GeoffM in post 138823 said:
Peter Bennet in post 138807 said:
Interestingly I tried launching on loader 5.8 which I still have and I get exactly the same problem. That suggests to me it's a problem linked to Window's, but I don't claim to be anything of an expert on computers.
That and the original post was before V5.15 of the Loader, and a few months after the previous version with no intermediate reports leads me to agree.

The GF window has its controls dynamically added at runtime, as opposed to nearly every other window in the Loader. The only one I can think of that adds dynamically is the Start New Simulation -> Select Options tab but that does not have any sliders.

For those that are having display issues and have Three Bridges, does the Coulsdon North GF work okay? Bear in mind there is a 120s timeout after pressing the F before the release can be taken. There are no sliders on this GF. Also, just to be sure, are the F3 (Options) -> Failures sliders working?
F3 sliders work for me.
I should add that, as I don't think it's been explicitly said, - GF tick boxes don't work for me either.

Wonder if there's any other program/website that loads in the same way?

Peter

I identify as half man half biscuit - crumbs!
Log in to reply
Lost My Levers! 19/04/2021 at 18:46 #138828
GeoffM
Avatar
5613 posts
Online
Peter Bennet in post 138827 said:
I should add that, as I don't think it's been explicitly said, - GF tick boxes don't work for me either.
When you say "don't work", do you mean they do not appear at all, or that the boxes are there but can't be clicked on? The latter is probably going to happen anyway if you can't release the frame - though as a dev, you can play with a test sim to prove that theory.

SimSig Boss
Log in to reply
Lost My Levers! 19/04/2021 at 19:19 #138829
Peter Bennet
Avatar
5023 posts
GeoffM in post 138828 said:
Peter Bennet in post 138827 said:
I should add that, as I don't think it's been explicitly said, - GF tick boxes don't work for me either.
When you say "don't work", do you mean they do not appear at all, or that the boxes are there but can't be clicked on? The latter is probably going to happen anyway if you can't release the frame - though as a dev, you can play with a test sim to prove that theory.
Everything appears OK but the TYP=S boxes, when clicked on briefly flicker but otherwise remain blank.
The TYP=P switches seem to fire up the EAR Command.

Peter

I identify as half man half biscuit - crumbs!
Last edited: 19/04/2021 at 19:19 by Peter Bennet
Reason: None given

Log in to reply
Lost My Levers! 19/04/2021 at 19:29 #138830
GeoffM
Avatar
5613 posts
Online
So my desktop PC had Windows 20H2 update installed and that was fine. My laptop was not on 20H2 and did exhibit the issue. Updating to the latest Windows update (twice) cured the issue - sliders now worked.

I'd appreciate if anybody else with the slider issue could check they are on the latest Windows version and report back.

SimSig Boss
Last edited: 19/04/2021 at 19:30 by GeoffM
Reason: Typo

Log in to reply
Lost My Levers! 19/04/2021 at 20:59 #138833
Peter Bennet
Avatar
5023 posts
GeoffM in post 138830 said:
So my desktop PC had Windows 20H2 update installed and that was fine. My laptop was not on 20H2 and did exhibit the issue. Updating to the latest Windows update (twice) cured the issue - sliders now worked.

I'd appreciate if anybody else with the slider issue could check they are on the latest Windows version and report back.
I've checked for updates and found 20H2 which I installed - no change to my experience - checked again and no updates outstanding.
I'll try uninstalling and see what happens and take it from there - never uninstalled an update before so not exactly sure what will happen, hopefully straight forward..

Peter

Edit - it's now asking me to restart again, so I'll try that first.

I identify as half man half biscuit - crumbs!
Last edited: 19/04/2021 at 21:01 by Peter Bennet
Reason: Further comment

Log in to reply
Lost My Levers! 19/04/2021 at 21:11 #138835
Peter Bennet
Avatar
5023 posts
That seemed to do it - all working as expected now.

Peter

I identify as half man half biscuit - crumbs!
Log in to reply
The following user said thank you: GeoffM
Lost My Levers! 19/04/2021 at 21:15 #138836
Steamer
Avatar
3580 posts
Online
Peter Bennet in post 138833 said:

Edit - it's now asking me to restart again, so I'll try that first.
For anyone unaware, Windows updates need a re-start to fully install. You'll also need to use the 'restart' option when performing this. (See here for the reason why: https://docs.microsoft.com/en-us/troubleshoot/windows-client/deployment/updates-not-install-with-fast-startup)

No issue on my PC, and 20H2 is installed.

"Don't stress/ relax/ let life roll off your backs./ Except for death and paying taxes/ everything in life.../ is only for now." (Avenue Q)
Last edited: 19/04/2021 at 21:15 by Steamer
Reason: None given

Log in to reply
Lost My Levers! 19/04/2021 at 22:15 #138837
rodney30
Avatar
140 posts
silly question how do you check what version of windows my laptop is running

many thanks

rodney 30

Log in to reply
Lost My Levers! 19/04/2021 at 22:23 #138838
GeoffM
Avatar
5613 posts
Online
rodney30 in post 138837 said:
silly question how do you check what version of windows my laptop is running

many thanks

rodney 30
Press the Windows button (either on the keyboard or in the bottom left of the screen) and start typing "about" (without the quotes). Click on "About your PC". You should see a section that says something like this:

Edition Windows 10 Home
Version 20H2
Installed on ‎4/‎19/‎2021
OS build 19042.928
Experience Windows Feature Experience Pack 120.2212.551.0

SimSig Boss
Log in to reply
The following user said thank you: rodney30
Lost My Levers! 19/04/2021 at 22:45 #138839
rodney30
Avatar
140 posts
Thanks Geoff. i have installed the latest update i have and i have version 1909 of windows 10.

Many thanks

Rodney 30

Log in to reply
Lost My Levers! 20/04/2021 at 10:21 #138844
Jan
Avatar
783 posts
Same here – my Desktop is on Windows 1909, and after installing KB5001337, all the scrollbars have disappeared. Searching around, users of other programs have reported problems as well, e.g. here.

Given that apparently support for 1909 is supposed to end next month anyway, I guess I'm indeed just going to update my Windows installation then…

Two million people attempt to use Birmingham's magnificent rail network every year, with just over a million of them managing to get further than Smethwick.
Last edited: 20/04/2021 at 10:21 by Jan
Reason: None given

Log in to reply
Lost My Levers! 20/04/2021 at 16:21 #138846
GeoffM
Avatar
5613 posts
Online
It looks like Microsoft broke scrollbars in KB5001337 and fixed it with the 20H2 update.

Other programs had the same issue and same solution as us

SimSig Boss
Log in to reply
Scrollbars Missing? Update Windows to 20H2 (ex Lost My Levers!) 23/04/2021 at 19:03 #138988
andyallen4014
Avatar
179 posts
Just to confirm that after downloading and installing the Windows Update (20H2) my levers and scrollers are now working. Not had the time to do it until today as these updates take a fair while to do!

Thanks to Geoff and John for looking into it.

Last edited: 23/04/2021 at 19:04 by andyallen4014
Reason: Added info

Log in to reply
The following user said thank you: GeoffM