Upcoming Games


Full list
Add a game

Upcoming Events

No events to display

We are not planning any more in-person events until the COVID-19 situation has improved.

Who's Online

Chaining Tool

You are here: Home > Forum > Announcements > Temporary postings > Chaining Tool

Page 2 of 2

Chaining Tool 20/01/2022 at 22:45 #143700
9pN1SEAp
Avatar
726 posts
Hi Broodje,

Looking in the error log on the web server, you uploaded two copies of KX, rather than a KX and a PBO. It should have sent an error message rather than an XML parsing failure, so I'll find out why error handling didn't work properly.

UPDATE: fixed the error, there was a missing slash in the /HEAD tag

Thanks
Jamie

Jamie S (JAMS)
Last edited: 20/01/2022 at 22:49 by 9pN1SEAp
Reason: None given

Log in to reply
Chaining Tool 21/01/2022 at 00:31 #143704
broodje
Avatar
169 posts
Ah, yes I did upload 2 wrong files once, but that generated the correct error. I'm still getting the same error when I try to compare the two 2012 Olympic timetables. I just tested at 00:30.
Log in to reply
Chaining Tool 21/01/2022 at 10:33 #143712
9pN1SEAp
Avatar
726 posts
Ooh, I’ll check later.
Jamie S (JAMS)
Log in to reply
Chaining Tool 21/01/2022 at 17:23 #143718
9pN1SEAp
Avatar
726 posts
Hi,

I couldn't find a logged error (a bug meant that the log wasn't saved - also now fixed).

Did the message say that the file format was invalid?

I've tweaked the script so that file errors should render as HTML not XML. I have also improved the stylesheet to handle errors that occur after unpacking, and further background logging of problems.

Do try again, hopefully we'll get to the bottom of this one :)

Thanks
Jamie

Jamie S (JAMS)
Log in to reply
Chaining Tool 21/01/2022 at 22:28 #143731
broodje
Avatar
169 posts
I've installed a English language pack for Firefox so I can actually understand what the error message is saying. It is really annoying when dutch translators think it is helpful to translate error messages for these kind of things. Anyway.. the error reads

XML Parsing Error: no root element found
Location: https://SimSig-tools.project76.net/cgi-bin/ttvalidate.php
Line Number 3, Column 1:

The funny thing is, when I intentionally upload files that I know that should not be working I get the proper errors. So the bright side is, your code is actually doing something and from my end the files are actually uploaded.

For example:
Side-By-Side Review
An error occurred
Don't know chaining from motherwell to hongkongeast - PM to JAMS

Log in to reply
Chaining Tool 21/01/2022 at 22:39 #143732
9pN1SEAp
Avatar
726 posts
Hi Broodje,

Very strange, here are the messages I see:

Jan 21 22:13:46 jovanka ttvalidatephp[1417]: 20091015.wtt: Invalid file format application/octet-stream
Jan 21 22:21:26 jovanka ttvalidatephp[1666699]: Invalid parameters.
Jan 21 22:26:12 jovanka apache[3336984]: ttvalidate Don't know chaining from motherwell to hongkongeast - PM to JAMS

I wonder if some browser plugin is interfering with the upload. Do you get the same problems if you use Edge or Chrome (or Safari, or anything other than Firefox!)

Jamie S (JAMS)
Log in to reply
Chaining Tool 21/01/2022 at 23:15 #143735
broodje
Avatar
169 posts
I do not have Chrome, but I do have edge and both should be using the same engine. Edge gives me a completely blank screen as result. When I try to compare an Euston TT with a PBRO tt I do get a result, but all columns are empty.

I do have some plugins in FF, but the result did not change when I disabled them all. I've also lowered all security settings, but this did not change anything.

Has anyone else tried the tool lately? Am I the only one with problems? Could it be a language settings problem? We use dots and commas in numbers differently when the language is set to dutch in windows. I mean 1.000 vs 1,000. In the past some software did brake on my machine because of that. But I assume all parsing of the files is done on the server, so that should not matter shouldn't it?

Log in to reply
Chaining Tool 21/01/2022 at 23:17 #143736
headshot119
Avatar
4374 posts
broodje in post 143735 said:
I do not have Chrome, but I do have edge and both should be using the same engine. Edge gives me a completely blank screen as result. When I try to compare an Euston TT with a PBRO tt I do get a result, but all columns are empty.

I do have some plugins in FF, but the result did not change when I disabled them all. I've also lowered all security settings, but this did not change anything.

Has anyone else tried the tool lately? Am I the only one with problems? Could it be a language settings problem? We use dots and commas in numbers differently when the language is set to dutch in windows. I mean 1.000 vs 1,000. In the past some software did brake on my machine because of that. But I assume all parsing of the files is done on the server, so that should not matter shouldn't it?
I used it recently on Chrome and never got a result returned, just a blank white screen.

"Passengers for New Lane, should be seated in the rear coach of the train " - Opinions are my own and not those of my employer
Log in to reply
Chaining Tool 22/01/2022 at 00:42 #143741
haydenrobertson
Avatar
49 posts
headshot119 in post 143736 said:
broodje in post 143735 said:
I do not have Chrome, but I do have edge and both should be using the same engine. Edge gives me a completely blank screen as result. When I try to compare an Euston TT with a PBRO tt I do get a result, but all columns are empty.

I do have some plugins in FF, but the result did not change when I disabled them all. I've also lowered all security settings, but this did not change anything.

Has anyone else tried the tool lately? Am I the only one with problems? Could it be a language settings problem? We use dots and commas in numbers differently when the language is set to dutch in windows. I mean 1.000 vs 1,000. In the past some software did brake on my machine because of that. But I assume all parsing of the files is done on the server, so that should not matter shouldn't it?
I used it recently on Chrome and never got a result returned, just a blank white screen.
I also used it recently on Chrome and got the same thing as above

Log in to reply
Chaining Tool 22/01/2022 at 21:36 #143764
9pN1SEAp
Avatar
726 posts
It's client-rendered XML, can take a couple of minutes to load.
Jamie S (JAMS)
Log in to reply
Chaining Tool 23/02/2022 at 19:13 #145333
9pN1SEAp
Avatar
726 posts
The tool is updated with Crewe and North Kent with the diagram updated.
Jamie S (JAMS)
Last edited: 23/02/2022 at 19:20 by headshot119
Reason: Corrected Link

Log in to reply
Chaining Tool 24/02/2022 at 10:14 #145357
phil1044
Avatar
143 posts
Hi Jamie,
I'm trying to run your chaining tool with several Mids TTs that I'm doing, but getting a blank screen after selecting the two timetables.
Iv'e tried various combinations using Rugby Centre, Rugby North and Coventry but not getting any results.
Iv'e not had any probs in the past when using it

Can you help please ?

Cheers
Phil

Log in to reply
Chaining Tool 24/02/2022 at 15:28 #145371
9pN1SEAp
Avatar
726 posts
You might need to wait bout 3 minutes for the results to appear, depending on the speed of your PC which has to render the data from XML on your browser.
Jamie S (JAMS)
Log in to reply
Chaining Tool 24/02/2022 at 16:26 #145378
phil1044
Avatar
143 posts
Ok cheers Jamie. I did wait a few minutes after reading your earlier posting, but nothing happened.
I'll give it another shot later on tho.

Thanks

Log in to reply
Chaining Tool 24/02/2022 at 17:01 #145381
Newhampshires
Avatar
99 posts
I have not had luck using the chaining tool lately. Figured it was something on my end.
Log in to reply
Chaining Tool 24/02/2022 at 21:43 #145384
9pN1SEAp
Avatar
726 posts
Hi all,

I'm not sure why some of you are getting blank screens, I suspect some plugin or anti-virus software is blocking XML rendering.

I'm working on fixing this with an asynchronous back-end renderer, should improve things. Experimental Version

Jamie S (JAMS)
Last edited: 24/02/2022 at 22:21 by 9pN1SEAp
Reason: None given

Log in to reply
The following user said thank you: phil1044
Chaining Tool 25/02/2022 at 12:35 #145393
phil1044
Avatar
143 posts
Hi Jamie,
that experimental version has worked fine this morning, thanks.

Phil

Log in to reply
Chaining Tool 25/02/2022 at 18:42 #145400
Newhampshires
Avatar
99 posts
Oh my goodness, the experimental version worked literally instantly. Thank you much. Development rages on....
Log in to reply